Back to overview
Downtime
Service disruptions
Oct 29 at 01:52pm CET
Affected services
Web login
Windows client login
Windows client info
Resolved
Oct 29 at 03:43pm CET
All services are online
Affected services
Windows client info
Web login
Windows client login
Created
Oct 29 at 01:52pm CET
Some of our customers may be experiencing service disruptions at the moment. We are actively working to resolve the issue and apologize for any inconvenience.
Affected services
Windows client info
Web login
Windows client login